Install / upgrade Linux Kernel to 3.18.3

Because it is not available via PPA, the needed deb packages of Kernel 3.18.1 are available via kernel.ubuntu.com. This installation should work on:

  • Ubuntu 15.04 vivid vervet
  • Ubuntu 14.10 Utopic Unicorn
  • Ubuntu 14.04 Trusty Tahr (LTS)
  • Linux Mint 17.1 Rebecca
  • Linux Mint 17 Qiana
  • Pinguy OS 14.04
  • Elementary OS 0.3 Freya
  • Elementary OS 0.2 Luna
  • Peppermint Five
  • Deepin 2014, LXLE 14.04
  • Linux Lite 2.0
  • Linux Lite 2.2
  • and other Ubuntu derivative systems

More info can be found here.